ToToTEK.COM Forum Index ToToTEK.COM
Help & Support Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

If you find any SPAM or any problem from the forum, please PM Tomy. Thanks.


CD64+ doesn't work

 
Post new topic   Reply to topic    ToToTEK.COM Forum Index -> Copiers and Hardware
View previous topic :: View next topic  
Author Message
lnfoss



Joined: 15 Feb 2017
Posts: 5

PostPosted: Sat Dec 15, 2018 8:03 pm    Post subject: CD64+ doesn't work Reply with quote

Hello Ali

I have had the opportunity To get a cd64+ (incl user manual) for free. The thing is that it doesnt work. The cdrom drive doesnt open (No light) and no interface at the screen. The N64 is working fine

i tested with another cd64+ and its working fine so n64 issue can be rejected

Question: where do i need To start To investigate in order To bring it To life again?

Thank you
Back to top
View user's profile Send private message
N340



Joined: 10 Feb 2019
Posts: 6

PostPosted: Sun Feb 10, 2019 5:13 am    Post subject: Reply with quote

So you need to start with Power and determining if the board and system is getting proper power. The fact that the system does not show power to the CD (light) drive, that tells me that it is not getting power through the whole system, or not posting and shutting down right away.

Like any system that runs on RAM, I would start there. Replace the RAM to start since you have a trial system

If you decide to sell it broken, I repair circuit boards and make customer PCBs for these things (RAM expansions for example). So if you want to sell it, i would offer you something for it.
Back to top
View user's profile Send private message
lnfoss



Joined: 15 Feb 2017
Posts: 5

PostPosted: Sun Feb 10, 2019 7:17 am    Post subject: Reply with quote

Hello. Thank you for your suggestion. I am not super familiar with this system so lot really sure how to test power through the board.. do you think replacing the RAM can fix it? Or a full review of the board is needed (And how can i do it)

If i cannot fix it i can sell it To you yes
Back to top
View user's profile Send private message
N340



Joined: 10 Feb 2019
Posts: 6

PostPosted: Sun Feb 10, 2019 1:44 pm    Post subject: Reply with quote

Well the RAM was just my suggestion for someone unfamiliar with proper diagnostics of PCBs and board components. Is it possible, yes but is it likely, no. I dont have a schematic for the cd64 plus but I would start looking for a burnt power component, likely a regulator. If you have a meter you can also test other i/o of each component till you find the issue.
Back to top
View user's profile Send private message
N340



Joined: 10 Feb 2019
Posts: 6

PostPosted: Tue Feb 12, 2019 3:56 am    Post subject: Reply with quote

Let me know if you need more help, can post images and I can look from images if you like. Just need pics of the PCB
Back to top
View user's profile Send private message
N340



Joined: 10 Feb 2019
Posts: 6

PostPosted: Tue Feb 26, 2019 1:51 am    Post subject: Reply with quote

Curious if you ever got it working.
Back to top
View user's profile Send private message
lnfoss



Joined: 15 Feb 2017
Posts: 5

PostPosted: Tue Feb 26, 2019 5:29 am    Post subject: Reply with quote

Hello. Sorry i had noopportunity To test so far but I Will keep you posted
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ToToTEK.COM Forum Index -> Copiers and Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2011 phpBB Group